HELP please! Speedodrive unit on G40 defect? Only one in Australia!

Chat about your MKIII (86C) inc GT/G40 Polo
Post Reply
Down_under_23582
New
Posts: 1
Joined: Sat Dec 19, 2020 8:57 am
Drives: Polo Mk3 1992 G40
Location: Alice Springs, Australia

HELP please! Speedodrive unit on G40 defect? Only one in Australia!

Post by Down_under_23582 »

Hey guys

I am the lucky owner of the only imported (12 years ago from UK) Mk3 1992 G40 in Capri green.

I bought it in poor condition, mechanicaly and started putting some love into in, in the middle of The Red Centre. I bought it of a guy in sydney. HAs been resprayed in the UK, somebody owned it there for 10 years.

Quick list of car. It obviously had a PSD 1341cc rebuilt 2006 incl. chipped ECU, also a rebuilt gearbox along the way, Jabbasport R1 supercharger rebuilt.
63mm supersport stainless steel. Sadly a horrible sounding original emptied cat converter. Will get a 100cell race cat.

I took the engine out, as no clutch left, CV joints and rubbers shot. Did timing belt, seals, gaskets, waterpump etc., gearbox linkage all over the place it got new bushings and a gear selector rebuilt kit, Oil breather plus hoses missing, and oil everywhere.

I rebuilt the GLader with a full kit from germany, incl. bearings, strips and seals.

With a innovate lambdatool i got it running very nicely. Not happy though with only 10PSI of boost on a SAAS gauge, what's your experience? Will try a VDO gauge shortly.

HEre is the Big question. Everything worked out well, the rebuilt etc. The only problem is that i don't have a speedo, its sometimes zero or it jumps and stops at 55mph. Now before everybody say change the cable or speedo. I have done following.

CHanged to brandnew speedo cable, nothing. I tried a second new one. And i also made sure that its clipped in the speedo dash and also nicely fed into the thread on gear box.

Nothing.

I thought its a speedp fault. Put the good old drill on the botton end of the cable and its working just fine, up to speed, no jumping.

I took the speedo gear out as well and inpsected, nothing wrong with it. Also installed a new one from heritage.

Nothing

The only idea i would have it that there is kind of a sleeve missing where the speedo drive actually rests in the gearbox, as it wobbles a bit and i have the impression that i can turn it a bit.

But i can't find anything, pics or topics about it and the inside of the gearbox


Didanybody have this problem? It would be awesome to get some help.

Regards

Seb
Attachments
IMG20200720163929 (Large).jpg
IMG20200720163929 (Large).jpg (533.59 KiB) Viewed 342 times
Post Reply